close

How to solve The `master` repo requires CocoaPods 0.32.1 error

QuestionsCategory: iOS (iPhone, iPad)How to solve The `master` repo requires CocoaPods 0.32.1 error
Tariq asked 9 months ago

I was working on an app and while installing pods I got this error.

The `master` repo requires CocoaPods 0.32.1

1 Answers
Chaudhary Talha Staff answered 9 months ago

First uninstall all the version of pods installed in your Mac:

$ sudo gem uninstall cocoapods
 
$ sudo rm -fr ~/.cocoapods/repos/master
 
$ sudo gem update --system --user-install
 
$ pod setup

If you get this error
 
[!] Unable to find the targets named `Project Name` and `Project Name Tests`to link with target definition `Pods`
 
after that

$ sudo gem uninstall cocoapods-try-release-fix
$ pod install

and it’ll be successful